Results 1 to 7 of 7

Thread: What at fault here out the two?? Injector help also.

  1. #1
    I'm a newbie
    Join Date
    Sep 2017
    Location
    Scotland - Central
    Posts
    13
    Feedback
    0

    What at fault here out the two?? Injector help also.

    Hi there got toyota Aristo 2jz gte engine, non vvti and it had the waterpump with built in system from hydrofan. Now i have removed the pump and replaced with a water pump from a toyota supra. The water pump fits perfectly however the new alternator i have is fouling the water pump so the top hole doesnt line up. The water pump was complete with back housing.

    Is the alternator or you think the Waterpump thats the problem.


    Pictures attached.


    looking for 800cc side fed injectors, any recommendations of where to get a set and what brand is best. I know you can get top feed rail but trying to avoid that if possible.
    Attached Images Attached Images

  2. #2
    Helpful Club Member Scooter's Avatar
    Join Date
    Aug 2002
    Location
    England - Surrey
    Posts
    10,584
    Feedback
    44 (100%)
    Have you got a picture further back from the front of the engine that shows the pump and alternator together?
    Number 8 ...........doing my best to keep
    Number 9 ........been and gone!
    Number 10 ........on its way

  3. #3
    I'm a newbie
    Join Date
    Sep 2017
    Location
    Scotland - Central
    Posts
    13
    Feedback
    0
    Will get some tomorrow mate thanks for reply


    Sent from my iPhone using Tapatalk

  4. #4
    I'm a newbie
    Join Date
    Sep 2017
    Location
    Scotland - Central
    Posts
    13
    Feedback
    0
    Right got some pictures today. Just cant seem to think why the alternator would foul the water pump.

    The pulley lines up with rest of the pulleys.

    To confirm its an aristo 2jz gte 1995 non vvti, i purchased a supra water pump kit and fitting it as i didnt want all the crap to do with the hydrofan. The water pump complete with back housing and was bolted on. The aristo alternator was then replaced with a supra alternator. Is the alternator slightly different?
    Attached Images Attached Images

  5. #5
    Helpful Club Member Scooter's Avatar
    Join Date
    Aug 2002
    Location
    England - Surrey
    Posts
    10,584
    Feedback
    44 (100%)
    This is my old alternator I need to repair, doesn't look much different, I think perhaps we need to measure?

    The line between the bolt holes seems to intersect the front pulley in the same place/plane

    Pic seems distorted!?
    Attached Images Attached Images
    Number 8 ...........doing my best to keep
    Number 9 ........been and gone!
    Number 10 ........on its way

  6. #6
    Helpful Club Member Scooter's Avatar
    Join Date
    Aug 2002
    Location
    England - Surrey
    Posts
    10,584
    Feedback
    44 (100%)
    Have you got a link to where you got the alternator from? Any part number on it at all?
    Number 8 ...........doing my best to keep
    Number 9 ........been and gone!
    Number 10 ........on its way

  7. #7
    I'm a newbie
    Join Date
    Sep 2017
    Location
    Scotland - Central
    Posts
    13
    Feedback
    0
    Here is pick of water pump and alternator for my aristo engine both supra items IMG_3337.JPGIMG_3336.JPG


    Sent from my iPhone using Tapatalk

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •