PDA

View Full Version : I hate my Supra! its cursed! seriously!



osso
08-12-03, 18:02
Since it was imported nearly 2 months ago its had both turbos replaced at the cost to Newera imports

and now I've got a serious boost leak somewhere within the system, im getting no boost whatsoever and the car is struggling big time coasting around at 20~30mph.. I've tried looking at the intercoolers but its a pain in the arse in the dark to see anything and my torch has died!! :banghead:

Wez
08-12-03, 18:12
If you are getting zero boost check all the inlet piping something must have popped off some where, same happened to me and it was the one that drops down from the throttle body, it came off where it connects to the plastic pipe below.

:thumbs:

osso
08-12-03, 18:15
Didnt you hear a hiss of escaping air when you had the same problem? i dont hear anything.. and i thought you would if such a large intake pipe becomes disconnected..

a mate of mine is at b&q as i speak, just asked him to get me a torch that plugs into the cig lighter.. so might be able to have another look later.

Wez
08-12-03, 18:22
Should be able to here something if you rev the engine but with that pipe blown off it wasn`t a hiss thats for sure.

:thumbs:

Wez
08-12-03, 18:23
Just thought another posibility with no boost could be wastegate stuck open or failing VSV which controls wastegate.

:conf:

JamesG
08-12-03, 18:35
Originally posted by osso

To top everything off, spoke to Miguel and he told me that he will not replace the aircon compressor. and advised that I should have taken out a warranty when I purchased the car.

I wouldn't stand for that given that you've only had the car for two months. Sounds like the aircon has been a problem since you bought it. Might be worth giving them another ring or writing them a strongly worded letter explaining your disatisfaction.

James.

Rob_B
08-12-03, 18:52
Sorry to hear that Osso.. Still haven't got my car back yet and something will probably go wrong when I do !

I would have thought they'd be oblidged to replace it after only 2 months.!! As James says, a strongly worded letter and maybe threatening some bad press about them may help :(

Failing that we could hold the next Supra meet at Newera imports and give them some serious stick :D

Hope you get it sorted mate.

Rgds,
Rob.

osso
08-12-03, 18:57
you're right JamesG, and since i've had the car over 2 months it hasnt been right... its been one thing and another. :( the last straw today was when the compressor siezed.. but first thing first i need to sort out the leak and get my car back on the road before i start with the letter..

Wez, it wont be the waste gate stuck open, because i am getting no pressure whatsoever from the pressure tank.. you should get a hiss when you remove the hose to the IACV VSV, which means it must be a leak from the main intercooler pipes... i hope!!

osso
08-12-03, 19:07
thanks Rob_B

I thought they would have oblidged to replace it, or at least investigate the problem, but i dont think bad mouthing them on here is the answer, after all they were very good replacing both turbos when i had a problem with the 2nd turbo since i collected the supra for the first time..

just a shame the motormall (newera's uk agents) who replaced the turbos screwed up when they reconnected the hose from the pressure tank and claimed that they have tested the supra and hooked up a boost gauge and told me the car was driving how a normal supra should! obviously not

Green Peace
08-12-03, 20:48
Originally posted by Rob_B
Sorry to hear that Osso.. Still haven't got my car back yet and something will probably go wrong when I do !

I would have thought they'd be oblidged to replace it after only 2 months.!! As James says, a strongly worded letter and maybe threatening some bad press about them may help :(

Failing that we could hold the next Supra meet at Newera imports and give them some serious stick :D

Hope you get it sorted mate.

Rgds,
Rob.

I agree with all of this...the Office Of Fair Trading is also a good place to call...I have found them really helpful, and its always good to register a complaint with them even if you decide not to take it further. Give the Company another chance but make it clear to them that you are prepaird to take things futher...

IF they refuse to come to the phone or return your calls then take it to the level discussed.

The way you have been treated is Unacceptable,

osso
08-12-03, 21:28
once i've got the car running and back on the road again, then i will approach Miguel again and sort out the problem with the air con compressor.. my main concern at the moment is the fact that my car isnt drive able at the moment.

I've just had a mate over and he has told me that the car is miss firing badly he could tell it was miss firing when the car was in idle and when we went out for very short drive up the road and back.. the car was struggling to make the revs.. if i put the gas to the floor in first gear it would struggle to make the revs and he thinks that because the car is missfiring badly its not producing the power to be able to create any pressure.. i kinda think this is plausible. what do you guys think? i definitely agree that the car is miss firing badly, but could this prevent any boost?

whats interesting is that the air filter case has cracked where it is bolted on to the body work, and he thinks that due to the fact that the car is miss firing the engine is probably shaking and snapped the plastic mount for the air filter casing..

Need4Speed
09-12-03, 00:43
seems like the dodgy compressor was putting a lot of strain on the engine before it seized up.. A bit unlikely, the Supra engine is a fairly powerful unit and a tight a/c compressor is not going to hold it back.

But sorry to hear of your woes, maybe a third party expert could give you an opinion on the "merchantable quality of the car".

Jake
09-12-03, 01:44
Osso, it sounds like the same problem I've had. Take the battery and battery tray out and look at the intercooler ducting down by the right hand side of the radiator, right at the bottom. Mine has come disconnected there 3 times now. It seems that it happens more in the cold weather, like we are having at the moment, what with the associated increased boost pressure that cold air temps bring.

MONKEYmark
09-12-03, 02:16
a 20,000 mile car should not have that kind of trouble. i have had intercooler pipe blow off at top on lefthand side of engine as you stood in front of it. maybe some real strong clips should sort it. you always think the worst when its not running right.
as soon as i put it back on it pulled like a train again. changing to colder plugs seems to get rid of misfires.

hope you get sorted soon

bet it will be something and nothing

trooper
09-12-03, 13:19
I've been following your woes Osso since the problems started. I've had my car a similar time.

Did you not get any Warrenty with the car? My bloke gave my 6 months for free and an option to buy more when that expires.

Newera surely can't afford bad press on this forum. People are always going to check out the web chat before going to a dealer.

If you have no comeback, what about a 50:50?

Gaz Walker
09-12-03, 13:26
All dealers have to warranty the engine and chassis for 3 months from purchase - regardless.

Gaz.

Green Peace
09-12-03, 13:49
Originally posted by Gaz Walker
All dealers have to warranty the engine and chassis for 3 months from purchase - regardless.

Gaz.

Good Point Gaz thats what I was thinking

osso
09-12-03, 14:46
spoke to trading standards earlier, and apparently thats not the case.. from what they told me :conf:

I've spoken to miguel this afternoon and I will now be taking the car back to motormall, :thumbs: he is convinced that the reason that the car is miss firing is because there's a huge air leak causing the car to overfuel in turn flooding the spark plugs which is causing the engine to missfire...

it sounds reasonable to me but i've no idea where the loose hose is and i definitely can not hear any farting hissing noise i would expect from a big 4" hose! :conf:

Jake
09-12-03, 19:21
Originally posted by osso
i've no idea where the loose hose is and i definitely can not hear any farting hissing noise i would expect from a big 4" hose! Did you look where I said? It's often there that they blow off. You'd be able to fix it in 15mins

Dragonball
09-12-03, 19:37
Originally posted by osso


it sounds reasonable to me but i've no idea where the loose hose is and i definitely can not hear any farting hissing noise i would expect from a big 4" hose! :conf:

That will not happen - you will just not get any boost at all m8

Soonto"HAS"soop
09-12-03, 19:54
Osso mate, if you're gonna go back to Motormall, tell me when and I can pop over with ya/meet you there, I only live 30 minutes away. I bought mine from them and they are depserate to see it again now that I have done some stuff to it :conf:. I also have some questions about some paintwork that they did and my Air Con is also knackered!! :mad:

PM me and give me a date/time if ya want.

Ben..

osso
09-12-03, 20:22
Jake - unforunately i've not had the chance to look, i simply do not have the basic equipment such as a light source! :eek: I wake up and goto work when its dark and i get home when its dark so im stuffed. i've got an old miniture torch but all my batteries have died! borrowed my mates yesterday and his torch was useless and died as well...

I did have a quick look when the RAC bloke came this morning, but didnt see anything a miss having said that i never took the battery out and have a really good look..

Paul E - are you saying you wont get any farting noise or hissing because there's no boost? would you normally expect serious miss fire when you have a massive air leak from a disconnected 4" hose?

Soonto"HAS"soop - Unfortunately i wont be going to motormall tomorrow, the plan is RAC will be transporting it over to motormall, well they said they would if the local toyota dealers wont touch grey imports.. so im gonna phone RAC tomorrow and get it organised, whats wrong with your air con? do you have a flashing green light where the AC button is? or are you just getting warm air when the air con is on? cuz if you are it needs regassing 60 quid jobby... I should be able to meet you when i collect the car back from motormall but i've no idea when this will be yet :(

Soonto"HAS"soop
09-12-03, 20:29
Originally posted by osso
Soonto"HAS"soop - Unfortunately i wont be going to motormall tomorrow, the plan is RAC will be transporting it over to motormall, well they said they would if the local toyota dealers wont touch grey imports.. so im gonna phone RAC tomorrow and get it organised, whats wrong with your air con? do you have a flashing green light where the AC button is? or are you just getting warm air when the air con is on? cuz if you are it needs regassing 60 quid jobby... I should be able to meet you when i collect the car back from motormall but i've no idea when this will be yet :(

No probs mate, I can get over there whenever. My Air Con does need to be regassed, but it seems that it needs regassing cos it's lost all of the fluid!! :eek: :eek: Didn't want to get it regassed for it all to leak out of the bottom again, and it seems that my warranty from Motormall covers "anything" wrong with the air con up to the value of 700, so even regassing is covered (apparently). My main problems is the paintwork, the rear quarter lights (red ovals) had rust around them when I went to view the car, so they "fixed" it, and it has come back after less than 3-4 months :mad: :mad: . So I need them to look at it again, but I doubt they will redo it.

Just drop me a PM if you're about, I may even be able to persuade a couple of other soop owners over.

Ben..

osso
09-12-03, 21:02
Rust? :O I didnt think cars rust these days! :conf: sounds good about persuade a couple of other soop owners, could cruise up to maidstone and hijack Sexsons carpark and have some donuts :D

osso
10-12-03, 07:08
:angry: damn RAC monkeys! bloke who came out to me yesterday said RAC would take my car to folkestone if i cant get it seen to by the local toyota dealerships in my area cuz my membership covers this.. phoned RAC this morning and the operator is telling me that they wont take the car over 15-20 miles away..

Folkestone is only 35 miles away! and they are moaning about the other 15 miles! i've not called them out in 2 years and this is the service i get? :twak:

osso
10-12-03, 07:44
OMG!! just phoned RAC again and spoke to another operator and told them what the problem was and that my car needs to be transported over to folkstone.. and the reply "not a problem sir a RAC approved contract transport vehicle will be with me in 60 minutes"

I'm glad i didnt tell him i phoned 30 minutes ago! and I told the second operator exactly what i told the first one, only this time i got a result! :conf:

Jake
10-12-03, 17:57
Originally posted by osso
Paul E - are you saying you wont get any farting noise or hissing because there's no boost? would you normally expect serious miss fire when you have a massive air leak from a disconnected 4" hose?( My intercooler ducting has blown apart three times and each time the car still ran perfectly apart from there being zero boost. The first time it did it I was really worried but PaulE told me exactly where to look (http://www.mkivsupra.net/vbb/showthread.php?s=&threadid=13444) and he was right. So it's obviously a weak spot.

Mid'lifecry'sis
11-12-03, 17:59
I cant read the whole thread - no time - but Dude fixed my 0 boost when the intercooler pipe poppoed - took ages to see where cos it looked like it was secure!

good luck - ;)

osso
11-12-03, 18:32
The problem has been found, it turned out to be one knackered spark plug which didnt have a gap! the spark gap has completely closed up :eek: apparently my spark plugs were none standard and had twin electrodes.. no idea why one of the plugs have closed up.. they've done a compression test and the engine seems to be fine.

Darren
11-12-03, 20:26
Originally posted by osso
The problem has been found, it turned out to be one knackered spark plug which didnt have a gap! the spark gap has completely closed up :eek: apparently my spark plugs were none standard and had twin electrodes.. no idea why one of the plugs have closed up.. they've done a compression test and the engine seems to be fine.

Plugs sometimes close up when bits of engine hit them....:eek: :(

I really hope this isn't the case.

Hopefully the compression test means theres not a problem.

osso
11-12-03, 20:56
you're good at cheering people up! :twak: :p

Dragonball
11-12-03, 23:09
Originally posted by osso
you're good at cheering people up! :twak: :p

LMFAO

Yeah closed plugs usually mean that the engine is suffering from chronic widget failure and must be given away to tall dark Gemini's whose name begins with P

Presently all my female 'aquaintances' seem preoccupied by star signs - whats all that crap about?

(funny enough - and on a separate subject - thats what my ex wife was told by a fortune teller.

...Shame I didnt visit one to be told I would marry a blood sucking bitch-leech!):p

Darren
12-12-03, 10:14
Originally posted by osso
you're good at cheering people up! :twak: :p

Sorry the truth often hurts!!!!:( :( :( :(